Overview of jUpgrade and how it works

Overview of jUpgrade and how it works

jUpgrade is a migration tool written for Joomla! 1.5, designed to assist administrators in moving the contents of their site into a new Joomla! 2.5 installation so they can "upgrade" their current site and enjoy all the benefits of the new Joomla features (such as nested categories and an expanded access control level system).


At the core it is a simple Joomla 1.5 component that will download a version of Joomla 2.5, decompress it and install it. After that, it should migrate all of the data from old Joomla 1.5 to the new Joomla 2.5 installation. jUpgrade uses Mootools for AJAX connections in order to make the migration independently.


jUpgrade will primarily migrate data for the core Joomla! components that are shared between 1.5 and 2.5, including:

JUpgrade Page 1 - Core content migrated.gif
  • Joomla Users - registered user accounts and their group access levels
  • Standard Joomla Modules - records for installed modules, any module parameters and menu associations
  • Joomla Categories - all sections and categories listed in the "Section Manager" and "Category Manager"
  • Joomla Content - all articles listed in the "Article Manager", including those marked as "Featured"
  • Joomla Menus - all menus listed in the "Menu Manager" (and all the menu items for each)
  • Joomla Banners - any banners that have been created and the banner categories that they have been organized into
  • Joomla Contacts - any contacts that have been stored and the contact categories that they have been organized into
  • Joomla Newsfeeds - any newsfeeds that have been created and the newsfeed categories that they have been organized into
  • Joomla Weblinks - any weblinks that have been stored and the weblink categories that they have been organized into
  • Joomla Images and media
  • Standard Joomla 1.5 Templates - migrated templates require minimal manual intervention to ensure compatibility with 2.5


jUpgrade also comes with a framework to extend transferring of content to specific third party extensions. More information supporting further components is available in the "Third party extension" section (coming soon), however the following components are natively supported:


The minimum requirements to run jUpgrade include:

  • PHP 5.2.x series or above
  • Curl module of PHP enabled
  • Joomla 1.5 (preferably latest)
  • Enabled "System - Mootools Upgrade" plugin that is included in Joomla 1.5.19 and greater.
  • A Browser with Javascript/Mootools support

JUpgrade Page 1 - Matias Aguirre author pic.jpg

jUpgrade is being maintained by its author, Matias Aguirre, who started the project in late 2010. It was in response to one of the biggest challenges facing Joomla! 1.6 at the time, which was the lack of a clearly defined migration path to get from Joomla 1.5 to 1.6. Since there were several significant architectural differences between Joomla 1.5 and 1.6 (which eventually evolved into the 2.5 we have today), Matias recognized the need users would have for a simple and effective solution. More of his personal notes are included in the interview he had with Joomla Community Magazine.

Matias is also the author of mtwMigrator, the popular component that helped administrator migrate their Joomla! 1.0 data to Joomla! 1.5 sites. Like its successor, mtwMigrator was able to migrate users, sections, categories, articles, menus and modules. And like its successor, it supported the migration of data for third party extensions, such as Community Builder, Docman, Fireboard and JomComment.


While the process of migrating your Joomla! 1.5 site to 2.5 is designed to be as smooth as possible, there are situations where further clarification or assistance will be required to deal with certain issues that may arise. In addition to the contents of this online documentation manual, further support can be found within the jUpgrade forums on the Matware boards.

Newsletter

Quick contact

If you need to contact us below the tracks offer direct contact: